Author Topic: No mouse movement in native games  (Read 1524 times)

Refalm

  • Administrator
  • Member
  • ***
  • Posts: 5,181
  • Kudos: 704
  • Sjembek!
    • RADIOKNOP
No mouse movement in native games
« on: 3 November 2010, 11:09 »
No one seems to be able to help me with this.

Mouse movement in Linux native games doesn't work. Not on my USB mouse or mousepad.
Games like Urban Terror, Warsow, Duke Nukem 3D (eduke32), Sauerbraten, etc.

Ironically, games in Wine (Team Fortress 2, Peggle Deluxe, Worms Reloaded, etc.) and JAVA (Minecraft) work great.

This is my hardware:
Intel Core2 Duo T8100 @ 2.10GHz
3 GB RAM
GeForce 8600GT 512MB (current driver 260.19.12)
Razer Salmosa
Synaptics Mousepad

I run Ubuntu 10.10. In Ubuntu 10.04, Linux native games worked.

Refalm

  • Administrator
  • Member
  • ***
  • Posts: 5,181
  • Kudos: 704
  • Sjembek!
    • RADIOKNOP
Re: No mouse movement in native games
« Reply #1 on: 5 November 2010, 18:18 »
Here's the solution:

In /etc/X11/xorg.conf add this:
Code: [Select]
Section "Module"
SubSection "extmod"
Option    "omit xfree86-dga"
EndSubSection
EndSection

Lead Head

  • Global Moderator
  • Member
  • ***
  • Posts: 1,508
  • Kudos: 534
Re: No mouse movement in native games
« Reply #2 on: 5 November 2010, 20:02 »
Is this related to your Graphics Drivers, or did your X-Config get screwed somehow?
sig.

Refalm

  • Administrator
  • Member
  • ***
  • Posts: 5,181
  • Kudos: 704
  • Sjembek!
    • RADIOKNOP
Re: No mouse movement in native games
« Reply #3 on: 5 November 2010, 20:47 »
The problem was in the beta nvidia driver and SDL not communicating mouse movement.

Lead Head

  • Global Moderator
  • Member
  • ***
  • Posts: 1,508
  • Kudos: 534
Re: No mouse movement in native games
« Reply #4 on: 9 November 2010, 04:05 »
Interesting bug, Is it just with Ubuntu 10.10?
sig.

Refalm

  • Administrator
  • Member
  • ***
  • Posts: 5,181
  • Kudos: 704
  • Sjembek!
    • RADIOKNOP
Re: No mouse movement in native games
« Reply #5 on: 9 November 2010, 09:55 »
I didn't have any problems in 10.04, but that could be because 10.04 had nvidia driver 195 and 10.10 has nvidia driver 260.